Creating Deformable Shapes

When building models in Rhino, you should first determine which methods should be used for each part of the project. There are two basic ways to model in Rhino—free-form and accurate. Some models require more attention to exact dimensions because they might have to be manufactured or parts may have to fit together. Sometimes it is the shape of the object, not the accuracy that is important. These techniques can be merged together to create accurate, free-form shapes. This tutorial focuses only on the free-form, squishy aspect. The exact size and placement of the objects is not critical. The overall form is the main objective.

This exercise shows:

- Simple surface creation
- Surface rebuilding
- Control point editing
- Curve creation (drawing, projecting)
- Splitting surfaces with curves and surfaces
- Blending between two surfaces
- Lighting and rendering

When you model the rubber ducky, you will use similar modeling techniques for the head and the body. You will create spheres that will be deformed to make the shapes.

If you need to know more about control points and surfaces, search the Rhino Help index for “control points.”
Exercise 54—Creating a rubber duck

1. Start a new model, use the Small Objects - Millimeters.3dm template. Save as Duck.

2. You can use layers to separate your parts, but for this model, it is not necessary.
   For more information about layers, look up “layer” in the Rhino Help index.

Create the body and head shapes

The body and head of the ducky are created by modifying two spheres. The size and placement of the spheres does not need to be exact.

To create the basic shapes:

1. From the Solid menu, click Sphere, and then click Center, Radius.
2. Pick a point in the Front viewport.
3. Pick another point in the same viewport to create a sphere.
4. Repeat this procedure for the second sphere.
To make the spheres deformable:

1. Select both spheres.
2. From the Edit menu, click Rebuild.
3. In the Rebuild Surface dialog box, change the Point Count to 8 for both U and V.
4. Change the Degree to 3 for both U and V.
5. Check Delete Input, clear Current Layer, and click OK.

The spheres are now deformable. Having more control points allows more control over smaller parts of the surface. A degree-three surface will have a smoother shape when deformed.
To modify the body shape:

1. Select the large sphere.
2. From the Edit menu, click Control Points, and then click Control Points On.
3. In the Front viewport select the control points near the bottom of the sphere.
   To window select, drag a box left to right around the control points.
4. From the Transform menu, click Set Points.
5. In the Set Points dialog box check Set Z, and Align to World as illustrated above.
6. Drag the selected control points up, snap to one of the upper most points.
   This aligns all of the selected control points to the same world z-value (vertical in Front viewport), flattening the surface.

To scale the sphere shape:

1. Turn off control points and select the body shape.
2. From the Transform menu, click Scale, and then click Scale1D.
3. For the Origin point, pick a point near the center of the body sphere.
4. For the First reference point, with Ortho on, pick a point to the right in the Front viewport.
5. For the Second reference point, pick a point further to the right in the Front viewport.
   The body is shaped like an ellipsoid.
To reshape the chest and tail

1. Turn the control points on.
2. Window select the control points at the top right of the body, and drag them to the right to bulge out the chest.

3. Window select the control points at the upper left edge of the body, and drag them up to form the tail.

Notice in the Top viewport that two control points are selected, though in the Front viewport, it looks like only one is selected. This is because the second control point is directly behind the one you can see in the Front viewport.
To add control for further shaping the tail:

Before we start to edit the tail further, we will add an additional set of points to the tail portion of the body.

1. From the **Edit** menu, click **Control Points**, and then click **Insert Knot**.

2. For the **Surface for knot insertion**, pick the body surface.
   A surface isocurve will be displayed. It will either be in the U or the V direction.

3. Change the direction if necessary.

4. For the **Point on surface to add knot**, pick a point midway between the tail and the center of the body.

5. Press **Enter** to end the command.
   A new set of isocurves and a new row of points have been added to the body.

6. Window select the control points at the upper part of the new isocurve, and drag them down to further form the tail and the body.

7. You can adjust the control points further until you get the shape you want.

8. **Save** your model.

**Notes:**

Insert Knot

Remember to use a window to select the control points. There may be multiple control points in the same location in this view.
To create the head:

1. In the **Front** viewport, select the small sphere.
2. From the **Edit** menu, click **Control Points**, and then click **Control Points On**.
3. Select the control points on the right side and drag them to begin forming the bill.

4. Window select the control points further back on the same isocurve and drag them forward to widen the bill.

5. Window select control points at the top of the bill and drag them down as shown.

6. Press **Esc** to turn control points off.

**Notes:**

Remember to use a window to select the control points. There may be multiple control points in the same location in this view.
Separate the bill from the head

For the final rendering, the bill must be a different color from the body. To do this, they must be separate surfaces. You can split a single surface into multiple surfaces many ways. The following technique is just one.

To split a surface with a curve:

1. In the **Front** viewport create a curve that looks like the illustration on the right.
2. Select the head.
3. From the **Edit** menu, click **Split**.
4. For the **Cutting object**, pick the curve you just created.
5. Press **Enter**.

The bill and head are now separate surfaces. This will allow you to render the surfaces with different colors.
Create the duck's neck

The ducky needs a neck. You will first make an edge on the surface of the head and a corresponding edge on the surface of the body so you can create a blended surface between the two edges.

To trim the head and the body:

1. Draw a Line across the bottom of the head.
2. Make a copy of the line and adjust it so that it intersects the top of the body as illustrated on the right.
   
   It is important that the lines intersect the bottom of the head and the body completely.
3. Select the lines.
4. From the Edit menu, click Trim.

5. For the Object to trim, pick the bottom of the head and the top of the body.
   
   The bottom of the head and the top of the body is trimmed.
6. Save your model.
To create the blend surface between the head and body:

1. From the **Surface** menu, click **Blend Surface**.
2. For the **Segment for first edge**, pick the edge curve at the bottom of the head.
3. If the whole edge is not selected, click **All** on the command line.
4. Press **Enter** to go to the next stage of the command.
5. For the **Segment for second edge**, pick the edge curve at the top of the hole in the body.
6. If the whole edge is not selected, click **All** on the command line.
7. Press **Enter** to go to the next stage of the command.

8. In the **Blend Bulge** dialog box, check the **Preview** check box.
   The blend surface between the body and the head is displayed.
9. Make any adjustments you desire by moving the slider bars in the dialog box, click **OK** when finished.
   If you check the box at the left of the sliders the surface adjustments are symmetrical.
10. **Save** your model.

To join the parts:

1. Select the body the blend surface and the back of the head.
2. From the **Edit** menu, click **Join**.
   The three surfaces are joined into one. The bill is left separate for rendering purposes.
To make an eye:
For this part of the exercise we will make a curve and revolve it to get the surfaces for the eye.

1. Toggle **Ortho** and **Snap** on to help.
2. From the **Curve** menu, click **Conic**.
3. In the **Front** or **Right** viewport make a conic curve as illustrated.
   **Start of Conic (1), End of Conic (2), Apex (3), Curvature point.**
4. Use **SmartTrack**, with **Point, End** and **Int** osnaps on, to help place the two points as illustrated.
   These points will be used for placement of the eye on the head.
5. From the **Curve** menu, click **Point Object**, then click **Multiple Points**.
6. For the **Location of point object**, hover over the end of the conic until the point activates, drag you cursor down and click to place the point.
   The point should be placed above the lower end of the conic.
   This will be the insertion point for eye.
7. For the **Location of point object**, hover over the point you just made until the point activates, drag you cursor left and click when you reach the intersection point.
   This point is for scaling and rotating the eye.
To split the curve:

1. Draw a line that intersects the conic
2. Select the conic curve,
3. From the Edit menu, click Split.
4. For the Cutting object, select the line.
   Splitting the curve allows you to assign a different color and material properties for the eye and the pupil.
   This step can be done at this stage or after you make the surface.

To make the surface:

1. Select both parts of the conic curve.
2. From the Surface menu, click Revolve.
3. For the Start of revolve axis, snap to the point.
4. For the End of revolve axis, snap to the end of the conic.
5. For the Start Angle, click FullCircle.
To assign display color and material color:

1. Select the top of the eye.
2. From the Edit menu, click Object Properties.
3. For the Display color, choose a contrasting color.
4. In the Properties window, on the Material page, click Basic, click on the Color button, and select a color for the pupil of the eye, like black.
5. Repeat these steps for the lower part of the surface. Set the color for both object display and material to white.
6. From the Render menu, click Render Preview to see the material color.

To place the eye on the head:

1. In the Top viewport, select both parts of the eye.
2. From the Edit menu, click Groups, then click Group.
   The eye parts are grouped as one object.
3. Select the group.
4. From the Transform menu, click Orient, then click On Surface.
5. For Reference point 1, snap to the point at the center of the eye.
6. For Reference point 2, snap to the point at the edge of the eye.
7. For Surface to Orient on, pick the head.
8 In the Orient on Surface dialog, check Uniform and Rigid, click OK.
9 For the Point of surface to orient to, pick a point on the head.

10 Mirror the eye to the other side of the head.

Render a picture of the ducky
Rendering creates a “realistic” picture of your model with colors you assign. These render colors are different from the layer colors you might be using, which control the display in wireframe and shaded mode.

To render the ducky:
1 Select the beak.
2 From the Edit menu, click Object Properties.
3 In the Properties window, on the Material page, click Basic and click the color swatch.
4 In the Select Color dialog box, select a color for the beak, like orange.
5 Select the body.
6 From the Edit menu, click Object Properties.
7 In the Properties window, on the Material page, check Basic and select a color for the body, like yellow.
8 From the Render menu, click Render.
To place lights:
1. From the Render menu, click Create Spotlight.
2. Select a point in the middle of the model.

3. Drag the radius until it is approximately three times as large as the model.
4. Pick a point in the Top viewport while holding the Ctrl key down to activate elevator mode. In the Front viewport pick a point slightly above the object.
5. From the Render menu, click Render.